Category Archives: Ruby

Installation of gem RMagick in Debian GNU/Linux

When installing RMagick gem you could step into some troubles with building this gem. Probably you are missing some development packages. In my case this was imagemagick itself plus some development headers:

Can't install RMagick 2.13.1. Can't find MagickWand.h.

apt-file search MagickWand.h showed that package libmagickwand-dev includes this file. So quick

apt-get install imagemagick libmagickwand-dev

solve this problem. After that¬†gem install rmagick -v ‘2.13.1’ ¬†finished with success.

Number of Views :63251